42

App loses connection to server after some time


N
Nuno Vitorino

Some customers are reporting the app is losing connection to the backend after the app in on background or sleeping for some time.
We suspect this is related to the OS closing connections after being inactive for some time and we are investigating the issue. In the meantime, try accessing to Innuos Sense via browser on my.innuos.com as in most cases the issue does not reproduce there.

A

Activity Newest / Oldest

Avatar

DJP

Sorry for late entry on this but have been away. Noticed that if I open Innuos sense on my iPad and then move to browse or other tasks - email for eg - and then come back to Innuos sense, it has lost connection. I need to delete the Innuos Sense App and then re-install ! Music choice still continues to play!


M

guardajoias

2.0.6 did solve the issue for me...


Avatar

Dan Petri

Could I test the beta version?


Avatar

Mike Hughes

I’m on beta 2.06 and it is marginally better at retaining connection when the app is minimised but still doesn’t do so consistently. Muses no difference whether I use Sense or the web version.


K

Digger

After following the advice regarding battery optimisation and updating to 2.06 I initially thought the issue had been resolved unfortunately this is not the case. As others have posted the issue is really random. I can go several hours with no problems but on another occasion the issue occurs within a few minutes and is persistent. Besides being unable to search or the Music tab showing no values to any category equally persistent is being presented with the 'Connect to Server' screen. I do believe the issue is becoming more frequent. Normally I can quickly establish a connection again but over the last week or so on at least two occasions trying to reconnect has failed even after several closures and opening of the app with no server being found.


Avatar

Haas

Ready to test beta FW 2.0.7 👍


N

Nuno Vitorino

We are making progress on this issue and expect soon to have a beta version of 2.0.7 with a fix. I'll contact some of you to test if you so wish.


  • M
Avatar

Jean-Pierre

Good news! Ready to test 2.0.7 as soon as possible if you wish. Thanks.


N

Nuno Vitorino

Status changed to: In progress

Avatar

anthony tait

Hi Nuno. I've updated to 2.0.6 but I'm still losing connection to the web based app. I've tried the battery optimization tip, using my Google Pixel 4XL, but it hasn't made any difference I'm afraid.
I've also been unable to use the mobile app for quite sometime now as it doesn't connect to the my Zenith MK2.


Avatar

Super_Legs

Hi, after the update to 2.0.6 I am still losing connection when on background. I am on a Ipad Pro 12.9 inch 2nd generation / ipadOS 14.8. The Innuos Sense app is also not visuable in the "Background App Refresh"-section on the Ipad settings / General section where refresh in background can be switched on and off. So maybe the problem / solution is in that part somewhere as it might be switched off automaticly? Running a Zenith MK3. Still happy face here though but nice if this can be solved.


N

Nuno Vitorino

Hi, given the reports that some of you still have issues with this I'm reopening the item. I may contact you directly to gather more information about this in order to determine why it's not working for you. For Android users, please apply the Battery Optimisation as described below anyway.


N

Nuno Vitorino

Status changed to: Under Review

M

Michael A.

Still not fully fixed for me. Android phone, Zen Mk3, Sense 2.0.6. Advanced through Music>Tidal>Artists>Albums>Play Album, then minimized the app and let it play for a few songs. When I pulled the app back up, and backed out to Albums under the Artist, other albums wouldn't load their tracks for viewing. I verified it wasn't just a Tidal issue because System Update wouldn't display the current version. Pausing/resuming didn't trigger a reconnection, so I let it sit for a minute or so, then tried backing out to the Artists page and it appeared to refresh them, and then I could go back in to the artist and it would load, as would the system version.
Power Saving Exclusion has remained in place for Sense since before the update.

After further time, it appears the apps behavior regarding connection is pretty random. I let it sit running the "working" spinner on an album for a few minutes maximized and it reestablished connection eventually and loaded the track list, almost like it's on a timer. But after a few minutes minimized, next time I tried to bring Sense back up from the open apps page, it reset the server connection and went to the Home area and cleared all states...
Soo, I let it continue playing the album it was, without searching anything, and switched to Twitter for about 10 or so minutes. I then returned to the app successfully, but it had lost server connection again, so I watched the Update version spinner turn for about 4 minutes, then I backed out of the server settings page and clicked System Update again and it instantly displayed the version. So pretty random.

A bit after that, I had an instance where the app just disappeared while sitting maximized during playback. I selected it from the open apps page and it restarted the app, of course losing states besides playback. These types of behavior, and other bizarre one-off GUI quirks happened with 2.0.5, so it's hard to say what may or may not be due to the .6 update.


Avatar

Marco Cinnirella

Not fixed for me. Zen Mark 3 uodated to 2.06 and Sense IOS app updated. I am using IOS 14 on an iphone 8 and an ipad Pro - with both the Sense app still loses connection - if anything it is WORSE now than before the update. The server becomes uncontrollable and the play/pause button does nothing on the Sense app, while the app shows a previous track and not the one currently playing - same behaviour as before the updates I am afraid


Avatar

Mike Hughes

This is listed as done but the behaviour persists for me.


Avatar

Phill R

My iPhone de (2020) still loses connection. I’ve reinstalled the app but no joy so have to use the IP address route


N

Nuno Vitorino

Status changed to: Done

N

Nuno Vitorino

We have now published the updates to the iOS and Android app to automatically refresh connections when app comes to foreground. However, on some Android devices it's still useful to add Sense to the Battery Optimization to prevent an initial re-connection. On iOS, so far on our tests it seems to recover the connections all the time now.


K

Digger

UPDATE: After six days the solution appears to work. Previously I was regularly loosing connection either on my Android 7 tablet or Android 11 phone (I had noted that often when one lost connection the other was still connected) resulting in having to close and reopen the app.
I have not suffered one 'full' drop out since changing the settings. On a couple of occasions when returning to the app I am no longer on the page where I left off but on the initial connection page with the ZenMini ready for connection. Tap and away we go. It could be that I accidentally caused these occurrences. As a matter of interest I never switch the Zen off.


K

Digger

I'm using a Samsung Galaxy Tab S2 (Android 7). The instructions given are not available as there is no 'App & Notification' option. However by going to 'Apps' there are three dots, press and 'Special Access' option appears. Select and first option is 'Optimise Battery'. Select and use the top drop down menu to select 'All Apps'. Find Innuos Sense and use on/off slider to switch off battery optimisation.


N

Nuno Vitorino

On my phone it's available on Apps > Special Access > Optimise Battery Usage on Andorid 11. Within apps, tab the options icon on the top right corner to list Special Access. Otherwise, try searching within Settings for "Optimise Battery Usage"


N

Obsydian

Not sure what version of Android you reference but for Android 11 there is no Apps & Notifications menu.

If it is just doze, then I found in by settings, apps, search Innuos, select Innuo Sense and then select battery, then optimise battery usage to disable doze.


N

Nuno Vitorino

For our users with Android devices, you can try this option on Settings:

1. Open your phone's Settings app.
2. Tap Apps & notifications And then Advanced And then Special app access And then Battery optimization.
3. On the Dropdown on Top choose "All Applications"
4. Search for Innuos Sense and disable Battery Optimization.

This should prevent Android from cutting off connections when the app goes to the background.

Drop a line in the comments if this works for you.


Avatar

Colin Goble

On my Android 8 tablet this option was under: Settings > Apps & notifications > Apps > Gear icon > Special access > Ignore battery optimisation > All apps > Innuos Sense > Allow. Seems to have suppressed the frequent 'Reconnecting to server' message.


Avatar

Colin Goble

Sadly, I've since had to revert the setting, as when I went back to the app after some time to select more music, there was no 'Reconnecting...' message but it would get stuck on the rotating "working" icon and the app had be restarted.


  • M
M

Michael A.

The override of power saving has not provided any improvement on my LG V30 either. After the phone sits for a while, even when Sense is maximized and playing through an album, the Tidal album list for a given artist I'd had open fails to load info when an album image is tapped-- rather the "working" spinner runs indefinitely. The track scrubber stays synced and responsive even when the phone is allowed to sleep and awoken, but web connection outside the local network appears to be lost.
I checked if this is only a Tidal connection issue by going to the "Server" area and checking for updates, and that spinner runs indefinitely as well. I have to reselect the server to regain web connection outside my network, which of course kicks me to the home page of the Music area clearing any search state I had arrived on before the phone


Avatar

Giovanni Boncompagni

to me it could be a problem of energy savings, the app goes in background and to reduce power consumption it sleep and loose server connection. I try to write every where... but it's possibile to have an always on control like OrangeSqueeze does? in notification menu and in lock screen? Like attached picture


  • Avatar
  • M
S

StewB

Same here, rebooting the app fixes it for the immediate time but it happens again as soon as I go off it. Web browser works OK so not a big issue, just a bit frustrating.


  • Avatar
L

Bech

I started using 2.04 3-5 days before upgrading to 2.05. I use Sense on an iPad. With 2.04 I had the problem a few times. Upgrading to 2.05 the problem did not occur until a few days ago. Now the problem occurs almost every time I switch back to the Sense app - ex. from Safari. If I restarts the Sense app it works again. But strange I had a period without problems.


  • Avatar
Avatar

DJP

Running Innuos Sense on iPad and also experiencing this problem if I go from IS to browser, for some time, and then return to IS. Music continues to play but I cannot control it from the App! I need to go back to “Server” and re start server using “select server” - this solves issue for a while.


  • Avatar
L

luke C

in fact, the IP address changed, so it works from the web but not with the app


  • Avatar
S

StewB

I went into my router and set the Innuos as a static IP address as when I had to reboot the router it changed all the ip addresses. No problem for a lot of connected items but it totally loses the server.


  • Avatar
C

Charles C

Other workaround is terminate and restart the app. Furthermore, it looks like one can connect to the innuos server by app or webbrowser from one device only.. currently I can only connect the app on the iPhone and using the webbrowser on the iPad. App on the iPad and webbrowser on the iPhone -> 'no innuos servers found' (both devices on the same network...)


  • Avatar
A

alan zelle

my.innuos is no longer finding server(Zenith Mk3). 2.5 successfully downloaded and operational for about a week. Manual entry and reboot change nothing. Roon works but not Sense.


  • Avatar
  • M
L

luke C

same for me


  • Avatar
L

luke C

?


  • Avatar
Avatar

Mike Hughes

Happens to me whether using app or browser.


  • Avatar
Avatar

Andy Kennedy

+1 Same here


  • Avatar
M

guardajoias

This happens very often in iOS app. It all happens when I swipe from Innuos Sense to another app and then swipe back...Does not happen indeed in browser view... This does not happen with iPeng.


  • Avatar
N

Nuno Vitorino

Status changed to: In progress